Solana RPC Provider Outage

Incident Report for LYS LABS

Resolved

This incident has been resolved.
Posted Jun 19, 2025 - 12:29 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 19, 2025 - 12:04 UTC

Update

We are continuing to investigate this issue.
Posted Jun 19, 2025 - 10:35 UTC

Update

Our upstream Solana RPC provider has confirmed a network disruption caused by an unexpected feature gate activation by the Solana network, which led to a temporary fork in part of the cluster.

This caused partial disruption to our transaction streaming and WebSocket API services.
The provider is actively mitigating the issue and reports that recovery is nearly complete.

We are continuing to monitor and will update once full service is restored.
Posted Jun 19, 2025 - 09:54 UTC

Investigating

We are currently investigating this issue.
Posted Jun 19, 2025 - 09:52 UTC
This incident affected: Third-Party Infrastructure (Solana RPC Node (External)), APIs (WebSocket API), and APP (Developer Portal).